BMPlus 3000 zone issue

Post your questions and comments here.
Post Reply
murf3030
Posts: 2
Joined: Wed Aug 31, 2022 7:55 pm

BMPlus 3000 zone issue

Post by murf3030 »

We moved into a new house that has a 2 zone system. I recently replaced the main floor thermostat with an ecobee4 unit. Once I did that, the upstairs zone is not working. When the board is reset, both dampers open and air flows as it should. Bothe the Zone 1 and Zone 2 lights are on. Air was flowing for a couple mins until the Zone 2 light shut off and the damper closed. It now has a red/amber light as opposed to the green light on the Zone 1 damper. Please help as it’s 80 degrees upstairs! Thanks in advance
murf3030
Posts: 2
Joined: Wed Aug 31, 2022 7:55 pm

Re: BMPlus 3000 zone issue

Post by murf3030 »

Ok, so an update to my issue. I did some troubleshooting and found out the old upstairs thermostat wasn't working correctly and was not sending a call to the system for AC. I swapped it out with the old downstairs unit and everything started working perfectly. However, overnight something changed. We woke up and it was like 62 degrees in the house, upstairs and downstairs. I went down to the BMPlus3000 board and the status light was flashing and only the Zone 1 and Zone 2 lights are illuminated. They Y1 and Y2 lights are not present and the AC is running non-stop. Any help would be greatly appreciated!

Thanks,
Tim
Steven W.
Posts: 58
Joined: Tue Jun 25, 2019 9:13 am

Re: BMPlus 3000 zone issue

Post by Steven W. »

I would recommend you give us a call and have volt meter on hand.
732-446-3110
Steven R. Weisneck
Technical Engineer
Tel: (732) 446-3110 Ext. #461
www.ewccontrols.com
sweisneck@ewccontrols.com
skowyrtka
Posts: 4
Joined: Tue Aug 31, 2021 7:00 pm

Re: BMPlus 3000 zone issue

Post by skowyrtka »

murf3030 wrote: Fri Sep 02, 2022 9:04 am Ok, so an update to my issue. I did some troubleshooting and found out the old upstairs thermostat wasn't working correctly and was not sending a call to the system for AC. I swapped it out with the old downstairs unit and everything started working perfectly. However, overnight something changed. We woke up and it was like 62 degrees in the house, upstairs and downstairs. I went down to the BMPlus3000 board and the status light was flashing and only the Zone 1 and Zone 2 lights are illuminated. They Y1 and Y2 lights are not present and the AC is running non-stop. Any help would be greatly appreciated!
https://filmekingyen.online/
Thanks,
Tim
I would be looking for a good service technician.
Post Reply