NCM300 - Heat Constanly Running

Post your questions and comments here.
Post Reply
leolfds
Posts: 2
Joined: Sun Jan 26, 2020 3:38 pm

NCM300 - Heat Constanly Running

Post by leolfds »

Hello All. I new to the Forum and looking for some advice/help with my heating system. I have a propane system with a NCM300 control board and 3 zones , each with Honeywell thermostats, model # TH6220U2000. Recently this winter I began to experience an anomaly with my system where the thermostats set temperature and the ambient temperatures would not match. First time it happened I woke in the middle of the night sweating. I checked all my thermostats and they were set to 65-68F, and the house's ambient temperature was registering 75-80F in all thermostats. I thought it might have been the programming on the thermostat from the previous owners so i turned it off and replaced the batteries in all thermostats to be sure and plugged them back on the wall. The system worked fine for a a few weeks and then it happened again. I pulled all the thermostats off the wall for a few hours and plugged them back in and everything seemed normal. Few weeks later it happened again. this time i went to the basement and checked the LED's on the NCM300 control board and all 3 zones were solid on, and the status LED blinking. I cycled power off and on to the system and it the system went back to normal. Recently I had a HVAC company come in and troubleshoot the system, wiring etc. and could not find anything wrong. Today my heating system is acting up again and I am starting to suspect if the control board might be the culprit and i am wondering how I can confirm? And if someone has experience the same and has a solution for it - reset, programming etc. Thank you!

My thermostat setting is is set to Heat, Fan Auto.

Steven W.
Posts: 24
Joined: Tue Jun 25, 2019 9:13 am

Re: NCM300 - Heat Constanly Running

Post by Steven W. »

Good morning

i have some questions about your problem please give me a call

Steven
732-446-3110 x461
Steven R. Weisneck
Technical Engineer
Tel: (732) 446-3110 Ext. #461
www.ewccontrols.com
sweisneck@ewccontrols.com

leolfds
Posts: 2
Joined: Sun Jan 26, 2020 3:38 pm

Re: NCM300 - Heat Constanly Running

Post by leolfds »

Hello Steven. I called no answer. Let me know a good time to call.

The HVAC system acted up again tonight. This time I tapped the black relays along the left-side on the control board with my finger and the heat turned off. I suspect one or two relays might be getting stuck causing the system to stay on.

Steven W.
Posts: 24
Joined: Tue Jun 25, 2019 9:13 am

Re: NCM300 - Heat Constanly Running

Post by Steven W. »

You need to replace your Zone board. Sounds like your relay is going.
Steven R. Weisneck
Technical Engineer
Tel: (732) 446-3110 Ext. #461
www.ewccontrols.com
sweisneck@ewccontrols.com

Post Reply