ComfortNet CTK04 displays wrong outdoor temperature

Post your questions and comments here.
Post Reply
npp
Posts: 1
Joined: Thu Jan 02, 2020 10:51 am

ComfortNet CTK04 displays wrong outdoor temperature

Post by npp »

Hello there,
In our two zone system, one CTK04 is displaying a constant outdoor temperature of 80F while the other one is correct.
They both read from the same Honeywell RedLINK Wireless outdoor air sensor.

This thermostat has been replaced weeks after its initial installation because it was displaying +6F above ambient INDOOR temperature. The replacement thermostat still shows +2F but I consider this acceptable. But the OUTDOOR is wrong!

Also, both thermostats used to display outdoor humidity, or am I mistaken?

Any advice how to remedy these problems?
Steven W.
Posts: 34
Joined: Tue Jun 25, 2019 9:13 am

Re: ComfortNet CTK04 displays wrong outdoor temperature

Post by Steven W. »

When you get a minute please give as a call today
(732) 446-3110
Steven R. Weisneck
Technical Engineer
Tel: (732) 446-3110 Ext. #461
www.ewccontrols.com
sweisneck@ewccontrols.com
Squitich35
Posts: 2
Joined: Wed Feb 21, 2018 11:26 am

Re: ComfortNet CTK04 displays wrong outdoor temperature

Post by Squitich35 »

I do have a wireless, but its only connected to one thermostat for fun. All should display the hardwired OAS inside the outside unit. But that one stat seems to be misreading it for some reason when the others are OK. I have removed the wireless from all stats just for troubleshooting.

Im just trying to figure out why one is misreading the hardwired from https://neotires.com/achilles-tires t-stat when the others are doing fine with it.
Post Reply