NCM300 Possible problem

Post your questions and comments here.
Locked
RIG
Posts: 1
Joined: Sat Dec 14, 2019 1:51 pm

NCM300 Possible problem

Post by RIG »

I have a Trane Gas Pack unit with 2 zones. each zone has its own thermostat. Zone 1 uses a Nest and Zone 2 uses a Honeywell programmable. Recently I have started having issues with the heat not coming on when I get up in the morning and move the Nest thermostat from 62 to 69. I have had the thermostat for almost 2 years and everything has worked fine until the last few weeks. The thermostat shows orange color (indicating it has told the heat to come on) but nothing happens. It doesn't do this every morning, just random morning. I can turn the temp back down and then back up more than once and finally the heat kicks on at some given point in the moving of the temp. I have done the same with the honeywell thermostat and get the same response. Could there be some sort of problem with the NCM300 not recognizing the temp has been bumped up? I went to the NCM300 board this morning after the heat finally decided to come on and the led lights looked normal based on the technical bulletin information. Could there be some part of the NCM300 starting to slowly go bad? Thanks for any advice.

Steven W.
Posts: 25
Joined: Tue Jun 25, 2019 9:13 am

Re: NCM300 Possible problem

Post by Steven W. »

When you get a free minute please give me a call about your problem.

732-446-3110 x461
Steven R. Weisneck
Steven R. Weisneck
Technical Engineer
Tel: (732) 446-3110 Ext. #461
www.ewccontrols.com
sweisneck@ewccontrols.com

Locked